Performance degradation with Journey Hub

Incident Report for Listrak

Resolved

The issue that prevented abandonment events from processing in Journey Hub has been resolved and events are now processing normally.
Posted Aug 26, 2026 - 10:14 EDT

Monitoring

We have identified and addressed the issue related to abandonment processing within Journey Hub. Backlogged data is being processed as services recover. We will provide a final update once fully resolved.
Posted Aug 25, 2026 - 14:52 EDT

Investigating

We have identified the issue affecting this experience and are working to restore normal performance. We will provide an update within 1 hour.
Posted Aug 25, 2026 - 14:07 EDT
This incident affected: Journey Hub (Abandonment).