Clients are unable to access admin.listrak.com

Incident Report for Listrak

Resolved

All systems are now fully recovered and operational.
Posted Apr 15, 2026 - 16:40 EDT

Monitoring

Engineers have corrected the impacted services and will continue to monitor.
Posted Apr 15, 2026 - 16:15 EDT

Update

Engineers are continuing to restore authentication services to a fully operational state.
Posted Apr 15, 2026 - 16:04 EDT

Identified

Engineers have identified an issue with a service that entered an unhealthy state. Corrective actions are being taken now. Clients might still see intermittent access issues while we continue to address the issue. This is not affecting any scheduled or transactional sends.
Posted Apr 15, 2026 - 15:49 EDT

Investigating

We are currently investigating reports that clients are unable to log into admin.listrak.com.
Posted Apr 15, 2026 - 15:36 EDT
This incident affected: Listrak App (Listrak App).