Email send, import, and export processing performance has been restored and is operating normally.
Posted Jul 09, 2026 - 11:32 EDT
Monitoring
We have implemented a fix, and performance has been restored. We are actively monitoring the system to ensure everything continues to operate normally. We will continue to provide updates as we monitor the situation.
Posted Jul 08, 2026 - 15:44 EDT
Identified
We have identified the issue affecting processing and are implementing a fix to restore normal performance. We will provide an update within 60 minutes.
Posted Jul 08, 2026 - 14:15 EDT
Investigating
Some clients may experience slower-than-usual processing of email sends, imports, and exports. We are actively investigating and working to restore normal performance. No data loss has been identified. We will provide an update within 60 minutes.
Posted Jul 08, 2026 - 13:17 EDT
This incident affected: Email (Email Broadcast, Email Transactional) and Imports and Exports.