Contact Profile User Interface

Incident Report for Listrak

Resolved

This incident has been resolved. All systems are operating normally.
Posted May 06, 2026 - 18:26 EDT

Monitoring

A fix has been implemented, and we are actively monitoring results to ensure full resolution. If you continue to experience issues loading profile details in the UI, please contact Listrak Support.
Posted May 06, 2026 - 17:16 EDT

Identified

The issue has been identified, and our team is actively working toward a resolution. We’ll continue to provide updates as progress is made.
Posted May 06, 2026 - 15:40 EDT

Investigating

We’re currently investigating an issue affecting the display of profile details for some clients on the NextGen Contact Profile page. This issue is limited to the user interface and does not impact message delivery or any customer sends.
Posted May 06, 2026 - 12:29 EDT
This incident affected: Listrak App (Listrak App).