NextGen Email Send Delays

Incident Report for Listrak

Resolved

NextGen Email services are operating at expected send times. We will continue to monitor these services for the duration of the AWS outage.
Posted May 08, 2026 - 16:25 EDT

Monitoring

We have completed mitigation steps related to the ongoing AWS outage. Our teams are actively monitoring systems to ensure continued stability and recovery.
Posted May 08, 2026 - 12:52 EDT

Identified

We are currently experiencing degraded performance with our NextGen services causing email sends to take longer than expected. This is due to an ongoing AWS outage. Our teams are actively working to restore full performance as quickly as possible.
Posted May 08, 2026 - 11:11 EDT
This incident affected: Email (Email Broadcast).