Performance degradation with contact management page

Incident Report for Listrak

Resolved

Contact management has been restored and is operating normally. No client action is required
Posted Jul 28, 2026 - 16:14 EDT

Identified

Some clients may experience intermittent errors with creating, editing or updating segments.
We have identified the issue affecting this experience and are working to restore normal performance.
There is no impact to sends that have already been scheduled.
We will provide an update within two hours.
Posted Jul 28, 2026 - 15:22 EDT
This incident affected: Segmentation.