Performance degradation

Incident Report for Listrak

Resolved

Our redirection services and media library have been restored and are operating normally.
Posted Sep 01, 2026 - 13:30 EDT

Monitoring

Clients may continue to experience issues with link redirection services and media library access.
Performance is improving as services continue to recover.
We will provide a final update once fully resolved.
Posted Sep 01, 2026 - 11:24 EDT

Investigating

Clients may experience degraded performance. We are actively investigating and working to restore normal performance. We will provide an update within 30 minutes.
Posted Sep 01, 2026 - 11:10 EDT
This incident affected: Listrak App (Listrak App).